{"action":"Upgrade sudo to 1.9.12-r1 or later.","affected":[{"fixed":"1.9.12-r1","introduced":"1.8.0"}],"component":"sudo","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.14","exploited":false,"fixed_versions":["1.9.12-r1"],"id":"tcs_01M5NEF3935EMJM7EN6JBY9K1G","modified_at":"2026-10-15T07:17:54.272651752Z","published_at":"2022-11-02T14:15:16.187Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-43995","https://security.alpinelinux.org/vuln/CVE-2022-43995"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-43995","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-43995"}],"summary":"Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered"}