{"action":"Upgrade ruby-faye to 1.4.0-1 or later.","affected":[{"fixed":"1.4.0-1","introduced":"0"}],"component":"ruby-faye","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.4.0-1"],"id":"tcs_01M5NEFT5TSA3FD20C8N71MN0Y","modified_at":"2026-10-26T12:01:17.651408495Z","published_at":"2020-04-29T18:15:13.360Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-11020","https://security-tracker.debian.org/tracker/CVE-2020-11020"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-11020","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-11020"}],"summary":"Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass ch"}