{"action":"Upgrade puma to 4.3.6-1 or later.","affected":[{"fixed":"4.3.6-1","introduced":"0"}],"component":"puma","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.3.6-1"],"id":"tcs_01M5NEG06X0W42K342KVBV0D5V","modified_at":"2026-10-26T12:01:20.463727642Z","published_at":"2020-05-22T15:15:11.363Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-11076","https://security-tracker.debian.org/tracker/CVE-2020-11076"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-11076","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-11076"}],"summary":"In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4."}