{"action":"Upgrade sudo to 1.9.12_p2-r0 or later.","affected":[{"fixed":"1.9.12_p2-r0","introduced":"1.8.0"}],"component":"sudo","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.14","exploited":false,"fixed_versions":["1.9.12_p2-r0"],"id":"tcs_01M5NEJXBX4WK7GCTC1W7R862Q","modified_at":"2026-10-26T17:17:58.607528689Z","published_at":"2023-01-18T17:15:10.353Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2023-22809","https://security.alpinelinux.org/vuln/CVE-2023-22809"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2023-22809","url":"https://osv.dev/vulnerability/ALPINE-CVE-2023-22809"}],"summary":"In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to appe"}