{"action":"Upgrade grub2 to 2.04-9 or later.","affected":[{"fixed":"2.04-9","introduced":"0"}],"component":"grub2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.04-9"],"id":"tcs_01M5NEKQW9VFE4G9T2Z20RPSWC","modified_at":"2026-10-26T12:01:35.512027440Z","published_at":"2020-07-29T20:15:12.397Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-14308","https://security-tracker.debian.org/tracker/CVE-2020-14308"],"severity":{"label":"medium","score":6.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-14308","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-14308"}],"summary":"In grub2 versions before 2.06 the grub memory allocator doesn't check for possible arithmetic overflows on the requested allocation size. This leads the function to return invalid memory allocations w"}