{"action":"Upgrade ruby-faye to 1.4.0-1 or later.","affected":[{"fixed":"1.4.0-1","introduced":"0"}],"component":"ruby-faye","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.4.0-1"],"id":"tcs_01M5NEMTK41XWSZ1TK3KQZWD10","modified_at":"2026-10-26T12:02:26.527837411Z","published_at":"2020-07-31T18:15:14.617Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-15134","https://security-tracker.debian.org/tracker/CVE-2020-15134"],"severity":{"label":"high","score":8.7},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-15134","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-15134"}],"summary":"Faye before version 1.4.0, there is a lack of certification validation in TLS handshakes. Faye uses em-http-request and faye-websocket in the Ruby version of its client. Those libraries both use the `"}