{"action":"Upgrade ndpi to 3.4-1 or later.","affected":[{"fixed":"3.4-1","introduced":"0"}],"component":"ndpi","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.4-1"],"id":"tcs_01M5NEN6M9473XWFS6PBTQ9AAD","modified_at":"2026-10-26T12:00:24.819396538Z","published_at":"2020-07-01T11:15:11.117Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-15472","https://security-tracker.debian.org/tracker/CVE-2020-15472"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-15472#Debian:13/ndpi","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-15472"}],"summary":"In nDPI through 3.2, the H.323 dissector is vulnerable to a heap-based buffer over-read in ndpi_search_h323 in lib/protocols/h323.c, as demonstrated by a payload packet length that is too short."}