{"action":"Upgrade ndpi to 3.4-1 or later.","affected":[{"fixed":"3.4-1","introduced":"0"}],"component":"ndpi","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.4-1"],"id":"tcs_01M5NEN6V3FC83BX3HMXTP1ERC","modified_at":"2026-10-26T12:00:42.975035663Z","published_at":"2020-07-01T11:15:11.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-15473","https://security-tracker.debian.org/tracker/CVE-2020-15473"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-15473","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-15473"}],"summary":"In nDPI through 3.2, the OpenVPN dissector is vulnerable to a heap-based buffer over-read in ndpi_search_openvpn in lib/protocols/openvpn.c."}