{"action":"Upgrade openssh to 9.1_p1-r3 or later.","affected":[{"fixed":"9.1_p1-r3","introduced":"8.9"}],"component":"openssh","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["9.1_p1-r3"],"id":"tcs_01M5NEND9HZ3CX4FMTZSZDN3GF","modified_at":"2026-10-26T17:17:58.618602388Z","published_at":"2023-03-17T04:15:14.553Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2023-28531","https://security.alpinelinux.org/vuln/CVE-2023-28531"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2023-28531#Alpine:v3.17/openssh","url":"https://osv.dev/vulnerability/ALPINE-CVE-2023-28531"}],"summary":"ssh-add in OpenSSH before 9.3 adds smartcard keys to ssh-agent without the intended per-hop destination constraints. The earliest affected version is 8.9."}