{"action":"Upgrade ghostscript to 9.54.0-r2 or later.","affected":[{"fixed":"9.54.0-r2","introduced":"0"}],"component":"ghostscript","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.14","exploited":false,"fixed_versions":["9.54.0-r2"],"id":"tcs_01M5NENMSD3VDY8J3H74MQEVFC","modified_at":"2026-10-26T17:17:58.619872Z","published_at":"2023-03-31T17:15:06.697Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2023-28879","https://security.alpinelinux.org/vuln/CVE-2023-28879"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2023-28879","url":"https://osv.dev/vulnerability/ALPINE-CVE-2023-28879"}],"summary":"In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TB"}