{"action":"Upgrade apache2 to 2.4.58-r0 or later.","affected":[{"fixed":"2.4.58-r0","introduced":"0"}],"component":"apache2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["2.4.58-r0"],"id":"tcs_01M5NENXBJYN1MVQVB02D2CWXN","modified_at":"2026-10-26T17:17:58.621780436Z","published_at":"2023-10-23T07:15:11.103Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2023-31122","https://security.alpinelinux.org/vuln/CVE-2023-31122"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2023-31122#Alpine:v3.18/apache2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2023-31122"}],"summary":"Out-of-bounds Read vulnerability in mod_macro of Apache HTTP Server.This issue affects Apache HTTP Server: through 2.4.57."}