{"action":"Upgrade lilypond to 2.22.1-1 or later.","affected":[{"fixed":"2.22.1-1","introduced":"0"}],"component":"lilypond","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.22.1-1"],"id":"tcs_01M5NEQNFJJYFSFCQ63VS7J7K9","modified_at":"2026-10-26T12:00:46.510415781Z","published_at":"2023-04-15T22:15:06.913Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-17354","https://security-tracker.debian.org/tracker/CVE-2020-17354"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-17354","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-17354"}],"summary":"LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary"}