{"action":"Upgrade strongswan to 5.9.12-r0 or later.","affected":[{"fixed":"5.9.12-r0","introduced":"5.3.0"}],"component":"strongswan","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["5.9.12-r0"],"id":"tcs_01M5NERHEMRJPT7JH4EYVM5CF5","modified_at":"2026-10-23T17:17:56.759354413Z","published_at":"2023-12-07T05:15:09.173Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2023-41913","https://security.alpinelinux.org/vuln/CVE-2023-41913"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2023-41913","url":"https://osv.dev/vulnerability/ALPINE-CVE-2023-41913"}],"summary":"strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code execution via a DH public value that exceeds the internal buffer in charon-tkm's DH proxy. The earliest affected"}