{"action":"Upgrade exim4 to 4.94.2-1 or later.","affected":[{"fixed":"4.94.2-1","introduced":"0"}],"component":"exim4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.94.2-1"],"id":"tcs_01M5NEZCDNP5M5SNJB2XF87260","modified_at":"2026-10-26T12:02:42.548513809Z","published_at":"2021-05-06T13:15:09.720Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-28024","https://security-tracker.debian.org/tracker/CVE-2020-28024"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-28024#Debian:13/exim4","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-28024"}],"summary":"Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers executing arbitrary commands, because smtp_ungetc was only intended to push back characters, but can a"}