{"action":"Upgrade jq to 1.8.0-r0 or later.","affected":[{"fixed":"1.8.0-r0","introduced":"0"}],"component":"jq","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.8.0-r0"],"id":"tcs_01M5NF07ZFHG575ZAQHF1K4H5V","modified_at":"2026-11-02T11:17:50.073897898Z","published_at":"2025-05-21T15:16:03.920Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-23337","https://security.alpinelinux.org/vuln/CVE-2024-23337"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-23337#Alpine:v3.24/jq","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-23337"}],"summary":"jq is a command-line JSON processor. In versions up to and including 1.7.1, an integer overflow arises when assigning value using an index of 2147483647, the signed integer limit. This causes a denial"}