{"action":"Upgrade node-socket.io-parser to 3.4.1-1 or later.","affected":[{"fixed":"3.4.1-1","introduced":"0"}],"component":"node-socket.io-parser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.4.1-1"],"id":"tcs_01M5NF29QTT6S09JC54XGV4X9M","modified_at":"2026-10-26T12:02:01.515235483Z","published_at":"2021-01-08T00:15:11.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-36049","https://security-tracker.debian.org/tracker/CVE-2020-36049"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-36049","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-36049"}],"summary":"socket.io-parser before 3.4.1 allows attackers to cause a denial of service (memory consumption) via a large packet because a concatenation approach is used."}