{"action":"Upgrade puma to 3.12.4-1 or later.","affected":[{"fixed":"3.12.4-1","introduced":"0"}],"component":"puma","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.12.4-1"],"id":"tcs_01M5NF4F94QTG5HE5J3RMSR9YZ","modified_at":"2026-10-26T12:02:04.056149692Z","published_at":"2020-02-28T17:15:12.220Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-5247","https://security-tracker.debian.org/tracker/CVE-2020-5247"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-5247","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-5247"}],"summary":"In Puma (RubyGem) before 4.3.2 and before 3.12.3, if an application using Puma allows untrusted input in a response header, an attacker can use newline characters (i.e. `CR`, `LF` or`/r`, `/n`) to end"}