{"action":"Upgrade openvpn to 2.6.11-r0 or later.","affected":[{"fixed":"2.6.11-r0","introduced":"2.6.0"}],"component":"openvpn","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["2.6.11-r0"],"id":"tcs_01M5NF6Y96DDC54MMXKFP4QHZQ","modified_at":"2026-09-15T08:17:48.495798069Z","published_at":"2025-01-06T14:15:08.807Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-5594","https://security.alpinelinux.org/vuln/CVE-2024-5594"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-5594#Alpine:v3.19/openvpn","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-5594"}],"summary":"OpenVPN before 2.6.11 does not santize PUSH_REPLY messages properly which an attacker controlling the server can use to inject unexpected arbitrary data ending up in client logs."}