{"action":"Upgrade binutils to 2.40-r8 or later.","affected":[{"fixed":"2.40-r8","introduced":"0"}],"component":"binutils","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["2.40-r8"],"id":"tcs_01M5NF884S6SP2B8T7GX8VR164","modified_at":"2026-08-27T22:18:02.754436188Z","published_at":"2025-01-29T20:15:35.007Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-0840","https://security.alpinelinux.org/vuln/CVE-2025-0840"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-0840","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-0840"}],"summary":"A vulnerability, which was classified as problematic, was found in GNU Binutils up to 2.43. This affects the function disassemble_bytes of the file binutils/objdump.c. The manipulation of the argument"}