{"action":"Upgrade rails to 2:5.2.0+dfsg-2 or later.","affected":[{"fixed":"2:5.2.0+dfsg-2","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:5.2.0+dfsg-2"],"id":"tcs_01M5NF8D41B978RJZXGSGBRMZ4","modified_at":"2026-10-26T12:02:24.258416849Z","published_at":"2020-07-02T19:15:12.433Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-8163","https://security-tracker.debian.org/tracker/CVE-2020-8163"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-8163","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-8163"}],"summary":"The is a code injection vulnerability in versions of Rails prior to 5.0.1 that wouldallow an attacker who controlled the `locals` argument of a `render` call to perform a RCE."}