{"action":"Upgrade rails to 2:5.2.4.3+dfsg-1 or later.","affected":[{"fixed":"2:5.2.4.3+dfsg-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2:5.2.4.3+dfsg-1"],"id":"tcs_01M5NF8E1YWH2A84MSHXJ01RNJ","modified_at":"2026-10-26T12:02:51.600280354Z","published_at":"2020-06-19T18:15:11.067Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-8165","https://security-tracker.debian.org/tracker/CVE-2020-8165"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-8165#Debian:14/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-8165"}],"summary":"A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an attacker to unmarshal user-provided objects in MemCacheStore and RedisCacheStore poten"}