{"action":"Upgrade weechat to 2.7.1-1 or later.","affected":[{"fixed":"2.7.1-1","introduced":"0"}],"component":"weechat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.7.1-1"],"id":"tcs_01M5NF9A274J86XPSRA683ZVS0","modified_at":"2026-10-26T12:02:45.243834332Z","published_at":"2020-02-12T22:15:13.207Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-8955","https://security-tracker.debian.org/tracker/CVE-2020-8955"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-8955#Debian:14/weechat","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-8955"}],"summary":"irc_mode_channel_update in plugins/irc/irc-mode.c in WeeChat through 2.7 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other"}