{"action":"Upgrade ruby-net-imap to 0.4.19-r0 or later.","affected":[{"fixed":"0.4.19-r0","introduced":"0"}],"component":"ruby-net-imap","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["0.4.19-r0"],"id":"tcs_01M5NFAG3DWS5A6SA07JE254D8","modified_at":"2026-08-27T22:18:02.856614336Z","published_at":"2025-03-04T00:15:31.550Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-27219","https://security.alpinelinux.org/vuln/CVE-2025-27219"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-27219#Alpine:v3.21/ruby-net-imap","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-27219"}],"summary":"In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of"}