{"action":"Upgrade sqlite to 3.44.2-r1 or later.","affected":[{"fixed":"3.44.2-r1","introduced":"3.44.0"}],"component":"sqlite","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["3.44.2-r1"],"id":"tcs_01M5NFB2Z6NK64YSF5XVJQE2YY","modified_at":"2026-08-27T22:18:02.872063350Z","published_at":"2025-04-07T20:15:20.253Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-29087","https://security.alpinelinux.org/vuln/CVE-2025-29087"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-29087","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-29087"}],"summary":"In SQLite 3.44.0 through 3.49.0 before 3.49.1, the concat_ws() SQL function can cause memory to be written beyond the end of a malloc-allocated buffer. If the separator argument is attacker-controlled"}