{"action":"Upgrade perl-authen-sasl to 2.1900 or later.","affected":[{"fixed":"2.1900","introduced":"0"}],"component":"perl-authen-sasl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["2.1900"],"id":"tcs_01M5NFC00RPPGQPPMCSD63J9PQ","modified_at":"2026-08-27T22:18:02.897038122Z","published_at":"2025-07-16T14:15:25.350Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-40918","https://security.alpinelinux.org/vuln/CVE-2025-40918"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-40918","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-40918"}],"summary":"Authen::SASL::Perl::DIGEST_MD5 versions 2.04 through 2.1800 for Perl generates the cnonce insecurely."}