{"action":"Upgrade ruby-net-imap to 0.4.22-r0 or later.","affected":[{"fixed":"0.4.22-r0","introduced":"0"}],"component":"ruby-net-imap","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["0.4.22-r0"],"id":"tcs_01M5NFC6KTYN6FE6R9Y8GEXW1M","modified_at":"2026-08-27T22:18:02.898858883Z","published_at":"2025-04-28T16:15:33.440Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-43857","https://security.alpinelinux.org/vuln/CVE-2025-43857"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-43857","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-43857"}],"summary":"Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.5.7, 0.4.20, 0.3.9, and 0.2.5, there is a possibility for denial of service by memory exh"}