{"action":"Upgrade ghostscript to 10.05.1-r0 or later.","affected":[{"fixed":"10.05.1-r0","introduced":"0"}],"component":"ghostscript","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["10.05.1-r0"],"id":"tcs_01M5NFCDY91CEJ05ZMV5VWM6MF","modified_at":"2026-08-27T22:18:02.903673396Z","published_at":"2025-04-26T15:15:45.057Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-46646","https://security.alpinelinux.org/vuln/CVE-2025-46646"],"severity":{"label":"medium","score":4.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-46646#Alpine:v3.22/ghostscript","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-46646"}],"summary":"In Artifex Ghostscript before 10.05.0, decode_utf8 in base/gp_utf8.c mishandles overlong UTF-8 encoding. NOTE: this issue exists because of an incomplete fix for CVE-2024-46954."}