{"action":"Upgrade quickjs-ng to 0.10.0-r0 or later.","affected":[{"fixed":"0.10.0-r0","introduced":"0"}],"component":"quickjs-ng","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["0.10.0-r0"],"id":"tcs_01M5NFCE8Z1Y6RPCYR2P2D3S6A","modified_at":"2026-08-27T22:18:02.903581137Z","published_at":"2025-04-27T20:15:15.720Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-46687","https://security.alpinelinux.org/vuln/CVE-2025-46687"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-46687","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-46687"}],"summary":"quickjs-ng through 0.9.0 has a missing length check in JS_ReadString for a string, leading to a heap-based buffer overflow. QuickJS before 2025-04-26 is also affected."}