{"action":"Upgrade apr-util to 1.6.4-r0 or later.","affected":[{"fixed":"1.6.4-r0","introduced":"1.2.0"}],"component":"apr-util","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["1.6.4-r0"],"id":"tcs_01M5NFD4TPVDMTET9SVPZR08NG","modified_at":"2026-08-27T22:18:02.987593541Z","published_at":"2026-08-06T15:16:41.890Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-49506","https://security.alpinelinux.org/vuln/CVE-2025-49506"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-49506","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-49506"}],"summary":"APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timin"}