{"action":"Upgrade rust-hyper to 0.14.19-1 or later.","affected":[{"fixed":"0.14.19-1","introduced":"0"}],"component":"rust-hyper","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.14.19-1"],"id":"tcs_01M5NFDBWTHSHZ38XCRB89J17W","modified_at":"2026-10-23T18:03:11.481077047Z","published_at":"2021-02-11T18:15:16.800Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-21299","https://security-tracker.debian.org/tracker/CVE-2021-21299"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-21299#Debian:13/rust-hyper","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-21299"}],"summary":"hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The"}