{"action":"Upgrade php7.4 to 7.4.21-1+deb11u1 or later.","affected":[{"fixed":"7.4.21-1+deb11u1","introduced":"0"}],"component":"php7.4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["7.4.21-1+deb11u1"],"id":"tcs_01M5NFDQS3851Z6PWZM5G7MPXC","modified_at":"2026-08-27T23:03:49.099542690Z","published_at":"2021-10-04T04:15:08.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-21705","https://security-tracker.debian.org/tracker/CVE-2021-21705"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-21705","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-21705"}],"summary":"In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid"}