{"action":"Upgrade cjson to 1.7.19-r0 or later.","affected":[{"fixed":"1.7.19-r0","introduced":"1.5.0"}],"component":"cjson","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["1.7.19-r0"],"id":"tcs_01M5NFE19T123YJHNAP0DAQQTY","modified_at":"2026-08-27T22:18:02.993056822Z","published_at":"2025-09-03T15:15:38.250Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-57052","https://security.alpinelinux.org/vuln/CVE-2025-57052"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-57052#Alpine:v3.23/cjson","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-57052"}],"summary":"cJSON 1.5.0 through 1.7.18 allows out-of-bounds access via the decode_array_index_from_pointer function in cJSON_Utils.c, allowing remote attackers to bypass array bounds checking and access restricte"}