{"action":"Upgrade rails to 2:6.0.3.5+dfsg-1 or later.","affected":[{"fixed":"2:6.0.3.5+dfsg-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2:6.0.3.5+dfsg-1"],"id":"tcs_01M5NFE8B9PFRM1CZ54A8G9TPC","modified_at":"2026-10-23T18:03:25.012913942Z","published_at":"2021-02-11T18:15:17.333Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-22880","https://security-tracker.debian.org/tracker/CVE-2021-22880"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-22880#Debian:13/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-22880"}],"summary":"The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validati"}