{"action":"Upgrade nodejs to 12.21.0~dfsg-1 or later.","affected":[{"fixed":"12.21.0~dfsg-1","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["12.21.0~dfsg-1"],"id":"tcs_01M5NFE92X6DYCYJ1561CA6BA6","modified_at":"2026-10-23T18:03:25.049768381Z","published_at":"2021-03-03T18:15:14.893Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-22883","https://security-tracker.debian.org/tracker/CVE-2021-22883"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-22883#Debian:13/nodejs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-22883"}],"summary":"Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of f"}