{"action":"Upgrade nodejs to 12.21.0~dfsg-1 or later.","affected":[{"fixed":"12.21.0~dfsg-1","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["12.21.0~dfsg-1"],"id":"tcs_01M5NFE99XWBNX11XGD5KB631X","modified_at":"2026-10-23T18:03:25.067534856Z","published_at":"2021-03-03T18:15:14.957Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-22884","https://security-tracker.debian.org/tracker/CVE-2021-22884"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-22884","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-22884"}],"summary":"Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to DNS rebinding attacks as the whitelist includes “localhost6”. When “localhost6” is not present in /etc/hosts, it is just an ordin"}