{"action":"Upgrade libuv1 to 1.40.0-2 or later.","affected":[{"fixed":"1.40.0-2","introduced":"0"}],"component":"libuv1","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.40.0-2"],"id":"tcs_01M5NFEBTBFHEB3DY6FS0MY777","modified_at":"2026-10-23T18:03:25.461128949Z","published_at":"2021-07-12T11:15:07.937Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-22918","https://security-tracker.debian.org/tracker/CVE-2021-22918"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-22918#Debian:13/libuv1","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-22918"}],"summary":"Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether"}