{"action":"Upgrade nodejs to 12.22.4~dfsg-1 or later.","affected":[{"fixed":"12.22.4~dfsg-1","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["12.22.4~dfsg-1"],"id":"tcs_01M5NFEDF7RPV2904EH16807SF","modified_at":"2026-10-23T18:03:25.069520500Z","published_at":"2021-10-07T14:15:08.053Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-22930","https://security-tracker.debian.org/tracker/CVE-2021-22930"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-22930#Debian:14/nodejs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-22930"}],"summary":"Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior."}