{"action":"Upgrade nodejs to 12.22.5~dfsg-1 or later.","affected":[{"fixed":"12.22.5~dfsg-1","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["12.22.5~dfsg-1"],"id":"tcs_01M5NFEDXT5V15GH9YJ5RSAFZB","modified_at":"2026-10-23T18:03:25.149643107Z","published_at":"2021-08-16T19:15:13.987Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-22940","https://security-tracker.debian.org/tracker/CVE-2021-22940"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-22940","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-22940"}],"summary":"Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior."}