{"action":"Upgrade htmldoc to 1.9.11-4 or later.","affected":[{"fixed":"1.9.11-4","introduced":"0"}],"component":"htmldoc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.9.11-4"],"id":"tcs_01M5NFEJC9X7F0MPRSV589K32S","modified_at":"2026-10-23T18:04:49.457578670Z","published_at":"2022-03-16T15:15:10.157Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-23165","https://security-tracker.debian.org/tracker/CVE-2021-23165"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-23165#Debian:13/htmldoc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-23165"}],"summary":"A flaw was found in htmldoc before v1.9.12. Heap buffer overflow in pspdf_prepare_outpages(), in ps-pdf.cxx may lead to execute arbitrary code and denial of service."}