{"action":"Upgrade golang-github-pires-go-proxyproto to 0.4.2-1 or later.","affected":[{"fixed":"0.4.2-1","introduced":"0"}],"component":"golang-github-pires-go-proxyproto","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.4.2-1"],"id":"tcs_01M5NFESXZ86B4PN0ZF32GPS1X","modified_at":"2026-10-23T18:04:49.907402013Z","published_at":"2021-03-08T05:15:12.593Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-23351","https://security-tracker.debian.org/tracker/CVE-2021-23351"],"severity":{"label":"medium","score":4.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-23351","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-23351"}],"summary":"The package github.com/pires/go-proxyproto before 0.5.0 are vulnerable to Denial of Service (DoS) via the parseVersion1() function. The reader in this package is a default bufio.Reader wrapping a net."}