{"action":"Upgrade node-hosted-git-info to 3.0.8-1 or later.","affected":[{"fixed":"3.0.8-1","introduced":"0"}],"component":"node-hosted-git-info","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.0.8-1"],"id":"tcs_01M5NFETWQFVQ5XAWVRCC8TCR5","modified_at":"2026-10-23T18:03:37.303393113Z","published_at":"2021-03-23T17:15:14.027Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-23362","https://security-tracker.debian.org/tracker/CVE-2021-23362"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-23362#Debian:14/node-hosted-git-info","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-23362"}],"summary":"The package hosted-git-info before 3.0.8 are vulnerable to Regular Expression Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl function in index.js. The affected regular e"}