{"action":"Upgrade node-postcss to 8.2.1+~cs5.3.23-7 or later.","affected":[{"fixed":"8.2.1+~cs5.3.23-7","introduced":"0"}],"component":"node-postcss","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["8.2.1+~cs5.3.23-7"],"id":"tcs_01M5NFEW5P6DK8PMC0R7EJMMTR","modified_at":"2026-10-23T18:03:37.005880250Z","published_at":"2021-04-26T16:15:07.330Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-23382","https://security-tracker.debian.org/tracker/CVE-2021-23382"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-23382","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-23382"}],"summary":"The package postcss before 8.2.13 are vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js. The vulnerable regexes are caused m"}