{"action":"Upgrade juce to 6.1.5~ds0-1 or later.","affected":[{"fixed":"6.1.5~ds0-1","introduced":"0"}],"component":"juce","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["6.1.5~ds0-1"],"id":"tcs_01M5NFF1EN5F9NS23P6YXQ9XBM","modified_at":"2026-10-23T18:03:11.984512142Z","published_at":"2022-01-31T11:15:07.820Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-23520","https://security-tracker.debian.org/tracker/CVE-2021-23520"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-23520#Debian:14/juce","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-23520"}],"summary":"The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability"}