{"action":"Upgrade pillow to 8.1.2+dfsg-0.2 or later.","affected":[{"fixed":"8.1.2+dfsg-0.2","introduced":"0"}],"component":"pillow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["8.1.2+dfsg-0.2"],"id":"tcs_01M5NFFRGXM8XBHJ0YN0GKDG0K","modified_at":"2026-10-23T18:02:41.084817898Z","published_at":"2021-06-02T16:15:08.650Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-25288","https://security-tracker.debian.org/tracker/CVE-2021-25288"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-25288#Debian:13/pillow","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-25288"}],"summary":"An issue was discovered in Pillow before 8.2.0. There is an out-of-bounds read in J2kDecode, in j2ku_gray_i."}