{"action":"Upgrade exim4 to 4.94.2-1 or later.","affected":[{"fixed":"4.94.2-1","introduced":"0"}],"component":"exim4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.94.2-1"],"id":"tcs_01M5NFGMQT2K99VKBY2JHMHE8K","modified_at":"2026-10-23T18:03:25.815834922Z","published_at":"2021-05-06T13:15:12.447Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-27216","https://security-tracker.debian.org/tracker/CVE-2021-27216"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-27216","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-27216"}],"summary":"Exim 4 before 4.94.2 has Execution with Unnecessary Privileges. By leveraging a delete_pid_file race condition, a local user can delete arbitrary files as root. This involves the -oP and -oPX options."}