{"action":"Upgrade glib2.0 to 2.66.7-1 or later.","affected":[{"fixed":"2.66.7-1","introduced":"0"}],"component":"glib2.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.66.7-1"],"id":"tcs_01M5NFGN1Q0K85YKDRT6TMKAJ6","modified_at":"2026-10-15T09:47:33.525639541Z","published_at":"2021-02-15T17:15:13.073Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-27218","https://security-tracker.debian.org/tracker/CVE-2021-27218"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-27218","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-27218"}],"summary":"An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated mod"}