{"action":"Upgrade perl-gd to 2.86-r0 or later.","affected":[{"fixed":"2.86-r0","introduced":"0"}],"component":"perl-gd","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["2.86-r0"],"id":"tcs_01M5NFGPCSAKS3C58E3K14WNSM","modified_at":"2026-10-01T02:17:49.169984292Z","published_at":"2026-06-14T12:16:22.403Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-11526","https://security.alpinelinux.org/vuln/CVE-2026-11526"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-11526#Alpine:v3.24/perl-gd","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-11526"}],"summary":"GD versions before 2.86 for Perl allow OS command injection and file overwrite via a 2-arg open() of filename arguments in _make_filehandle."}