{"action":"Upgrade node-ua-parser-js to 0.7.24+ds-1 or later.","affected":[{"fixed":"0.7.24+ds-1","introduced":"0"}],"component":"node-ua-parser-js","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.7.24+ds-1"],"id":"tcs_01M5NFGQKVQ1QC9F24VJFP534V","modified_at":"2026-10-23T18:02:57.726685282Z","published_at":"2021-03-17T13:15:15.200Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-27292","https://security-tracker.debian.org/tracker/CVE-2021-27292"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-27292#Debian:14/node-ua-parser-js","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-27292"}],"summary":"ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing"}