{"action":"Upgrade perl-dbi to 1.651-r0 or later.","affected":[{"fixed":"1.651-r0","introduced":"0"}],"component":"perl-dbi","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.651-r0"],"id":"tcs_01M5NFHW5XZA7DRKE6SZYG20J7","modified_at":"2026-10-01T02:17:49.188950685Z","published_at":"2026-07-07T23:16:54.090Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-14739","https://security.alpinelinux.org/vuln/CVE-2026-14739"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-14739","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-14739"}],"summary":"DBI versions before 1.650 for Perl have a heap overflow when preparsing SQL statements with an extreme number of placeholders."}