{"action":"Upgrade shibboleth-sp to 3.2.1+dfsg1-1 or later.","affected":[{"fixed":"3.2.1+dfsg1-1","introduced":"0"}],"component":"shibboleth-sp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.2.1+dfsg1-1"],"id":"tcs_01M5NFHZM5HH6M935CBRP401RN","modified_at":"2026-10-23T18:02:46.541028746Z","published_at":"2021-03-22T08:15:13.247Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-28963","https://security-tracker.debian.org/tracker/CVE-2021-28963"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-28963#Debian:14/shibboleth-sp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-28963"}],"summary":"Shibboleth Service Provider before 3.2.1 allows content injection because template generation uses attacker-controlled parameters."}